分类目录归档:Linux

用RouterOS作为远程DHCP服务器

Cisco的DHCP服务器太难用了,查询起来不直观,要设置个固定的release累死人。Linux上那一堆DHCP daemon也没好到哪里去。想了想作为DHCP服务器的话,最直观方便的也就RouterOS了。简要记述一下把RouterOS作为远程DHCP服务器(不接入客户端所在二层)的配置方法。

配置

三层交换机(Cisco IOS):首先我们关闭ip helper对除DHCP以外其它协议的转发;然后在接口上设置helper address为RouterOS的IP地址即可。

no ip forward-protocol udp
interface Vlan100
 ip address 192.168.1.1 255.255.255.0
 ip helper-address 192.168.0.2

RouterOS:对每个DHCP server配置,接口设置为转发包的来源接口,relay设置为三层交换机面向DHCP客户端的内网端口的IP。

/ip pool
add name=dhcp ranges=192.168.1.10-192.168.1.254
/ip dhcp-server
add address-pool=dhcp conflict-detection=no disabled=no interface=bridge name=user-vlan relay=192.168.1.1
/ip dhcp-server network
add address=192.168.1.0/24 gateway=192.168.1.1 netmask=24

调试

Cisco IOS上可以用debug ip dhcp server packetdebug ip dhcp server events看到每个请求的转发过程。

RouterOS DHCP lease里面出现大量busy是因为conflict detection没有关闭,这种配置下conflict detection时间很长,可能会导致部分客户端超时以后疯狂重试,进而吃光DHCP地址池。因此参考配置里面关掉了conflict detection。


参考:

迁移Proxmox VE(KVM)虚拟机到VMWare ESXi

迁移前的准备工作

  • 记录下VMID和VM信息的对应关系——Proxmox VE关机以后这些数据很难找到
  • 关闭所有虚拟机
  • 把所有LVM类型的存储上的硬盘迁移到local类型存储上,以便提取文件

如果你像我一样面前摆着一块离线的Proxmox VE硬盘,想知道VMID和虚拟机名的对应关系,那么可以前往/var/lib/pve-cluster/config.db,用SQLite 3打开。

转换磁盘格式(第一遍)

/var/lib/vz/images/{VMID}文件夹下找到对应的磁盘镜像文件,然后用qemu-img做转换:

qemu-img convert -f qcow2 -O vmdk -o adapter_type=lsilogic,subformat=streamOptimized,compat6 100/vm-100-disk-0.qcow2 vm-100-disk-0.vmdk

(虽然这里写了adapter_type=lsilogic,但是和之后具体使用什么虚拟adapter没有直接关系。)

如果遇到以下bug,那么请更新qemu-utils

error while converting vmdk: compat6 cannot be enabled with hwversion set

传输镜像到ESXi

用网页管理面板或者打开SSH服务以后用SCP传输都行。目标位置:/vmfs/volumes/{your_disk_name}/

转换磁盘格式(第二遍)

从普通vmdk转换成flat的vmdk以能被ESXi使用。

vmkfstools -d thin -i origin.vmdk converted.vmdk

注意这样转换出来的是两个文件:一个converted.vmdk是元数据,一个converted-flat.vmdk是硬盘数据,二者必须保持一致的命名,如果要移动必须一起移动。不要自己给硬盘文件取名的时候在后面加-flat,这会导致问题。

后续设置

配置了静态IP的虚拟机可能需要重新配置,因为网卡名变了。


参考: