RouterOS实现PPPoE单线多拨

单线多拨的关键在于假装一根线上有多个MAC地址。这可以用VRRP功能实现。

首先创建VRRP:

/interface vrrp
add interface=ether1-cmcc-uplink name=vrrp-cmcc-1 vrid=1
add interface=ether1-cmcc-uplink name=vrrp-cmcc-2 vrid=2

只需要保证vrid 不同就好。协议版本默认为3即可。

如果v3协议设置是IPv4,那么需要配置一下IP地址(随意找个不会冲突的即可)才能启用该interface。

/ip address
add address=240.0.0.1/24 comment="vrrp dummy" interface=vrrp-cmcc-1
add address=240.0.1.0/24 comment="vrrp dummy" interface=vrrp-cmcc-2

如果是IPv6则不需要做这一步。

然后在每个VRRP interface上创建PPPoE Client interface即可。

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据