启用 nginx 的 HTTP/2 支持

nginx 1.9.5 现已支持 HTTP/2 协议。

首先,使用 http://nginx.org/en/linux_packages.html#mainline 这里的方法添加 mainline 源,然后重新安装 nginx。(如果直接升级,由于 deb 包来自不同的源,可能会升级失败。)

如果提示是否覆盖文件,选择否。

最后,把 nginx 配置文件中的 spdy 关键字全部改成 http2,重启 nginx ,大功告成!

A screen capture of Chrome showing HTTP/2 has been enabled for blog.swineson.me

发表评论