分类目录归档:RouterOS

RouterOS 6.41以后版本基于端口的的VLAN设置方法

RouterOS日常改操作逻辑,尤其是6.41开始原来Switch菜单内容缩水他又改回去了,功能开始移动到Bridge菜单并且自动判断是否开启硬件加速以后,只能说越来越看不懂了。下面简单介绍一个RouterOS新版Bridge菜单的VLAN设置。

为了便于理解,本文统一使用Cisco VLAN记法:

  • 连接非交换设备,需要添加、移除VLAN标记的端口称为access端口;
  • 连接交换设备,不需要操作VLAN标记的端口称为trunk端口。

继续阅读

在RouterOS上使用Sierra Wireless MC/EM74xx系列LTE网卡的GPS功能

首先禁用网卡的NMEA功能,否则你是没有办法使用该网卡的任何channel的,禁用方法可以参考这篇文章。禁用后网卡会显示为三个channel:

编号功能
0AT指令
1GPS
2PPP和SMS

然后只需要设置正确的channel和启动命令:

# 设置 port 的名字
/port set <你的网卡 port 序号> baud-rate=auto name=em7455
# 配置 GPS 功能
/system gps set channel=1 enabled=yes init-string="\$GPS_STOP,\$GPS_START" port=em7455 set-system-time=yes

如果要看串口读出的原始数据的话,可以启用日志:

/system logging add topics=gps

配置成功后效果如图所示。


参考资料:

AirPort路由器的访客网络和其他品牌路由器的兼容性问题

AirPort会把访客网络加上VLAN tag 1003。如果AirPort直接接在RouterOS路由器上,可以通过以下命令将其加入桥:

/interface vlan add interface=<AirPort连接到的有线端口> name=vlan-airport-guest vlan-id=1003
/interface bridge port add bridge=bridge interface=vlan-airport-guest

如果需要隔离访客网络,请使用与主网络不同的bridge,并添加防火墙规则和bridge规则。

有些Managed Switch和AirPort一起使用存在兼容性问题。参见The Apple Airport’s Dirty Little Secret